Version PHP, extensions, et cache


Dans votre cPanel, vous pouvez changer la version PHP, allez à la section Logiciels, icone 'Sélectionner une version PHP'
(Si vous ne voyez pas l'icone 'Sélectionner une version PHP', ceci veut dire que vous êtes sur un serveur cPanel sans Cloudlinux, voir en bas de cet article la solution). Observez quelle est la version PHP utilisée actuelle : 'Current PHP version'

Par défaut vous êtes sur la version PHP 7 qui est la plus optimale/compatible au niveau performance avec opcache installé au niveau serveur.
Ce sélecteur PHP fourni par Cloudlinux applique une même version PHP à tous les domaines de votre compte cPanel.

NB : Si vous utilisez NGINX PHP-FPM : voir notre article dédié, les sélecteurs cloudlinux et cPanel ne fonctionnent pas

Comment changer de version PHP ?
Par le menu déroulant situé juste en dessous, sélectionnez la version, puis cliquez sur "Set as current", cette version s'applique à tous les domaines du compte.
Vous pouvez sur cette même page ajouter des extensions PHP par version PHP, choisissez ou enlevez selon votre besoin puis sauvegardez en bas.

 

Version PHP multiples

 

Vous pouvez aussi mettre une autre version PHP pour 1 ou plusieurs domaines de votre compte en ajoutant un morceau de code dans le htaccess à la racine du dossier du site web concerné ou du dossier si sous-dossier de site web :
Exemples:
1. Si vous voulez mettre PHP56 pour un site web au lieu qu'il utilise la version PHP7 qui est configurée par défaut pour tout le compte, ajoutez ceci au .htaccess
AddType application/x-httpd-alt-php56___lsphp .php5 .php4 .php .php3 .php2 .phtml
2. Si vous voulez mettre PHP71, ajoutez ceci au .htaccess
AddType application/x-httpd-alt-php71___lsphp .php5 .php4 .php .php3 .php2 .phtml

Pour personnaliser votre php.ini, c'est en cliquant à droite en haut sur "Switch to PHP Options" : appuyez sur la valeur du réglage que vous souhaitez modifier et sauvegardez en bas. Notre article en images :
https://hosting.yoorshop.fr/knowledgebase/115/Peut-on-personnaliser-le-fichier-phpini-.html

NB :
activer memcache dans Prestashop requiert d'ajouter le serveur 127.0.0.1
activer memcache dans Wordpress requiert d'ajouter l'extension de gestion de cache WP-FFPC ou similaire....


Serveurs cPanel sans Cloudlinux (hébergements personnalisés et HA)
Dans votre cPanel, à la section logiciels :
- l'icone MultiPHPmanager pour changer de version PHP par domaine
- l'icone MultiPHPini editor pour personnaliser le php.ini par domaine
Il n'y a aucune possibilité à votre niveau de choisir l'extension php, vous devez ouvrir un ticket et demander ce dont vous avez besoin.

Consultez aussi

Changer le mot de passe cPanel

Pour changer le mot de passe de votre compte cPanel, vous devez le faire depuis votre espace...

Peut-on personnaliser le fichier php.ini ?

Nous avons 2 types de serveurs : Cloudlinux-cPanel et cPanel, la méthode est différente...

Connexion distante bases de données MySQL

Nouvelle méthode depuis le 11 déc 2018 (Pour les offres Haute disponibilités, voir l'ancienne...

Utilisation de tâches cron

Nous considérons que ce message donné parfois par les scripts et applications pour la mise en...

Accès SSH par clé avec putty

Depuis juillet 2018, vous pouvez accéder au SSH par votre cPanel de manière directe et...

Besoin d'autre suggestions